Not working in Firefox 3.5

Aug 24, 2009 at 1:59 AM
Edited Aug 24, 2009 at 2:00 AM

I set up the control following the Quick Start Guide. I created a web page:

 

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html> 
<head>
    <title>Slide.Show 2 Quick Start Example</title> 
</head> 
<body>
    <object type="application/x-silverlight-2" data="data:application/x-silverlight-2,"
        width="640" height="480">
        <param name="background" value="black" />
        <param name="source" value="Vertigo.SlideShow.xap" />
        <param name="initParams" value="" />
     </object>
</body>
 </html>

 

then added the Vertigo.SlideShow.xap file to the same directory where the web page is located.

When I open the webpage in Firefox, all I see is nothing. In IE the black box shows like in the Quick Start Guide.

Is SlideShow 2.1 not working in Firefox?

 

 

May 21, 2010 at 5:21 PM

I am having the same problem.  Anyone resolve this?

Jun 2, 2010 at 7:28 PM
Edited Jun 2, 2010 at 7:52 PM
Your line: <param name="initParams" value="" should have something for the value.
 
In fact two items are needed, a configuration that formats the gallery and a data source that tells SS2 where your imgs are located.
 
For the configuration use either:
  • ConfigurationProvider="SimpleTheme"
    This is a built-in theme that comes with SS2.  Also try LightTheme and DarkTheme.
  • ConfigurationProvider=XmlConfigurationProvider;Path=Configuration.xml
    This is where you can really customize your gallery.  Configuration.xml is a file added to your project. Grab one of the samples to get started.  Messing around with this file is quite fun.  Dial in exactly how you want your gallery to look like.
For the data source use:
  • DataProvider=XmlDataProvider;Path=Data.xml
    Data.xml is a file that tells SS2 where your imgs are.  Also is a place to add titles and captions.  Look at one of the sample files to get started.  You will likely need to add a folder to contain your imgs.  This is where the data.xml file will 'point to'.
These two entries are separated by a comma.  Here is what mine looks like:
<param name="initParams" value="ConfigurationProvider=XmlConfigurationProvider;Path=Configuration.xml,DataProvider=XmlDataProvider;Path=Data.xml" />