Slide.Show 2 - Hide ToggleEmbedViewButton

May 21, 2009 at 5:14 AM

I have set the EmbedViewer Enabled="false" and the ToggleEmbedVieweButton Enabled="false", but the button still shows. What did I do wrong? Any help is greatly appreciated.

Thanks in advance.

Andy

May 26, 2009 at 7:04 PM

I got the same problem... Please help

Developer
Jun 17, 2009 at 5:40 AM
Edited Jun 17, 2009 at 9:58 AM

I wanted to do exactly the same thing and had trouble doing it using the XML configuration.  However, with the help of this post, I was able to very easily create a new theme that disabled the embedviewer...

http://slideshow2.codeplex.com/Thread/View.aspx?ThreadId=43529

Just copy the .cs file in the Configuration folder for the theme you want to mimic and then change the appropriate settings in the regions you want to change (for example, set Enabled = false in the ToggleEmbedViewButtonOptions section and in the EmbedViewer section).  Then open up App.xaml.cs and add your new theme to the case statement in InstantiateConfigurationProvider.  Recompile SlideShow, and copy the new Vertigo.SlideShow.xap file from the ClientBin to your web site.

Jun 17, 2009 at 7:14 AM

Brilliant. It worked like a charm. Thanks a million.

Developer
Jul 7, 2009 at 7:21 PM

FYI, the XML Configuration is broken in the original release.  See this discussion thread for details:

http://slideshow2.codeplex.com/Thread/View.aspx?ThreadId=39286

The good news is that it has been fixed in change set 25804. Note that the change set includes additional enhancements and bug fixes as well.

http://slideshow2.codeplex.com/SourceControl/changeset/view/25804

A new XML configuration sample has been added in change set 25845 that demonstrates how to use an xml configuration file to provide simple overrides of the default Light Theme:

http://slideshow2.codeplex.com/SourceControl/changeset/view/25845

A new custom theme is no longer necessary for simple modifications like the one described in this discussion thread.  There are times when it may still be useful though...