This project is read-only.

thumbnail doesn't show up; godaddy workaround?

Jan 19, 2009 at 9:54 PM
I have two questions.

First, I am trying to upgrade to Slideshow2, have the current version running. I couldn't get the thumbnail to show up on localhost; the album runs fine without error just doesn't have any thumbnail on the bottom. The source and thumbnails pictures are the same, I do not have smaller pictures for thumbnails.

Second, has anyone able to get Slideshow2 running on godaddy. I do not have the luxury to change MIME type on IIS.

Thank you!
Jan 20, 2009 at 2:28 PM
Please verify your file paths in your data provider, file paths are relative to the xap file.

From what your saying, I am assuming that your godaddy account is a shared server since you don't have access to the MIME types on IIS. You will need to contact godaddy and have them verify that you have the correct MIME type settings for silverlight 2. You will also need to get them to verify whether or not you have their hotlink protection running on your account and if possible have them turn it off. The hotlink protection will not allow silverlight access to download your images. This service can be configured to limit access to your resources. However, if your site is public and you would like the general public to have access to your slideshow, then you simply need to turn the hotlink protection off. At least this is what I ran into with godaddy's dedicated servers.
Jan 20, 2009 at 2:34 PM
Edited Jan 20, 2009 at 2:35 PM
Thank you Jeremy. I did contact godaddy. You are correct about shared hosting; I was told to cancel my current hosting account and start one because that's the only way to choose IIS 7. I am currently on IIS6. Even when I switch to IIS7, I will have to modify web.config to accomodate MIME type change. They will not handle it in IIS. Thank you for the information about hotlink, I will check with Godaddy.