HELP?! XmlConfigurationProvider

Jan 13, 2009 at 4:02 AM
Okay any help will be greatly appreciated.  I can get the slide show to work when using the light them or dark them.  However, I want to be able to remove the full screen button as an option along with the Embed button.  I have tried endless combinations to no avail.  Here is my code.


ASPX Page

<

 

asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" Runat="Server">
<script type="text/javascript" src="Silverlight.js"></script>
<script type="text/javascript" src="SlideShow.js"></script>
<script type="text/javascript">
        
new SlideShow.Control(new SlideShow.XmlConfigProvider({ url: "slideshow/configuration.xml" }));</script> 
    <td class="rightMainTable">
        <object type="application/x-silverlight-2" data="data:application/x-silverlight-2," width="575" height="480"> 
            <param name="background" value="black" /> 
            <param name="source" value="Vertigo.SlideShow.xap" /> 
            <param name="initParams" value="ConfigurationProvider=xmlConfigurationProvider;Path=configuration.xml,DataProvider=XmlDataProvider;Path=DataEvent2008.xml" /> 
            <a href="http://go.microsoft.com/fwlink/?LinkID=124807" style="text-decoration: none;"><img src="http://go.microsoft.com/fwlink/?LinkId=108181" alt="Get Microsoft Silverlight" style="border-style: none" /></a>
        </object>
    </td>
</asp:Content>

DATA.xml   (small sampling)

 

<?

 

xml version="1.0"?>
<
data transition="CrossFadeTransition">
<
album title="2008 Culinary Celebration Event Photos" image="2008Thumbnails/DSC_7961_t.jpg">
<
slide title="2008 Culinary Celebration" image="2008EventPhotos/DSC_7858.jpg" thumbnail="2008Thumbnails/DSC_7858_t.jpg" />
<
slide title="2008 Culinary Celebration" image="2008EventPhotos/DSC_7859.jpg" thumbnail="2008Thumbnails/DSC_7859_t.jpg" />
<
slide title="2008 Culinary Celebration" image="2008EventPhotos/DSC_7861.jpg" thumbnail="2008Thumbnails/DSC_7861_t.jpg" />

Configuration.xml  (have tried multiple values including ones from samples)

 

<?

 

xml version="1.0" encoding="utf-8" ?>
<
configuration width="575" height="500" background="RED">
<
module name="SlideDescription"></module>
<
module name="NavigationTray">
    <
option name="Enabled" value="true" />
    <
option name="BackgroundOpacity" value="1" />
    <
option name="Background" value="Red" />
</
module>

 

<

 

 

Module name="SlideNavigation"></Module>
<
module name="ThumbnailViewer"></module>
<
module name="slideThumbnail">
    <
option name="Enabled" value="true" />
</
module>
<
module name="SlidePreview">
    <
option name="Enabled" value="true" />
</
module>
<
module name="ToggleEmbedViewButton">
    <
option name="Enabled" value="false" />
</
module>
<
module name="ToggleAlbumViewButton">
    <
option name="Enabled" value="false" />
</
module>
<
module name="ToggleFullScreenButton">
</
module>
<
module name="EmbedViewer">
</
module>

 

 

<!--

 

 

<transitions>
<transition type="fadetransition" name="crossfadetransition" />
<transition type="wipetransition" name="wiperighttransition">
    <option name="direction" value="right" />
</transition>
</transitions>
-->

 

</

 

 

configuration>

I have the XAP file, the data.xml file, the configuration.xml file, as well as the silverlight.js, and slideshow.js files all in the same folder.  It seems that the ASPX page isn't seeing the XMLConfigurationProvider or the Configuration.xml page.  I didn't know if I needed to since neither the quick guide nor the advanced one said what files needed to be copied into your project.   I'm a newb when it comes to coding in VS.  Any help would be greatly appreciated!

 

 

 

 

Jan 15, 2009 at 12:16 AM
    Silverlight.js/sideshow.js is for Slide.Show controls, you don't need them while deploying Slide.Show2 controls.