Can't get it to work with VS2010

Jul 13, 2010 at 2:32 AM

i can't run it on vs 2010 and .net framework 4.0. In Page.xaml i am getting an error "Cannot create an instance of SlideDescription" which is weird because i can see the SlideDescription.cs file under "Controls" folder. Also this error is true too for "NavigationTray" and "EmbedViewer".

Aug 9, 2010 at 3:42 PM
Edited Aug 9, 2010 at 3:43 PM
I have the same issue with vs 2010 and blend 4. I can run the sample web project, but have the error using only the silverlight app. did you find a solution to this??
Aug 9, 2010 at 11:45 PM

No unfortunately i couldn't find any solution to this. I had to write my own slide show controller.

Jan 1, 2011 at 4:46 PM

Did you guys find the solution ? I'm having the same problem...khhashish is it possible to send your code ?

 

Thank you

Jan 22, 2011 at 4:48 PM

I got it to work after seeing the solution elsewhere. For the record I'm using Visual Web Developer Express 2010, and am on the DotNet framework 4. The problem is that the slideshow is using a deprecated System.Web.Silverlight reference that was used to host the silverlight control on your page (see my post here: http://betaforums.silverlight.net/forums/p/187847/513345.aspx), but has since been replaced by the object tag and javascript. Simply remove the reference and rebuild your solution and it will work.

One caveat: I have not been able to get the slideshow xaml view to work in Expression Blend 4, however, even after the above fix. But the slideshow will compile and and run if you follow the above--you'll just have to use the code view in Blend to make any edits. If it won't compile in Blend for you at all, I suggest just using VWDE to compile since it works fine there.