This project is read-only.

Cannot get to work in Expression Web 3

Apr 26, 2010 at 8:29 PM

I am getting the following error when running the testpage in an expression web 3 generated application.  Can someone point me in the right direction please?  Thanks.

 

Webpage error details

 

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; GTB6.4; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; Tablet PC 2.0)

Timestamp: Mon, 26 Apr 2010 19:14:11 UTC

 

 

Message: Unhandled Error in Silverlight Application

Code: 4004  

Category: ManagedRuntimeError      

Message: System.Xml.XmlException: [Xml_TagMismatchEx]

Arguments: slide,8,4,album,14,4

Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.50401.0&File=System.Xml.dll&Key=Xml_TagMismatchEx

   at System.Xml.XmlTextReaderImpl.Throw(Exception e)

   at System.Xml.XmlTextReaderImpl.Throw(String res, String[] args)

   at System.Xml.XmlTextReaderImpl.ThrowTagMismatch(NodeData startTag)

   at System.Xml.XmlTextReaderImpl.ParseEndElement()

   at System.Xml.XmlTextReaderImpl.ParseElementContent()

   at System.Xml.XmlTextReaderImpl.Read()

   at System.Xml.XmlSubtreeReader.Read()

   at System.Xml.XmlSubtreeReader.Read()

   at System.Xml.XmlReader.MoveToContent()

   at System.Xml.XmlReader.IsStartElement()

   at Vertigo.SlideShow.XmlDataProvider.ParseSlides(XmlReader reader, String inheritTransition)

   at Vertigo.SlideShow.XmlDataProvider.ParseAlbums(XmlReader reader, String dataTransition)

   at Vertigo.SlideShow.XmlDataProvider.client_DownloadStringCompleted(Object sender, DownloadStringCompletedEventArgs e)

   at System.Net.WebClient.OnDownloadStringCompleted(DownloadStringCompletedEventArgs e)

   at System.Net.WebClient.DownloadStringOperationCompleted(Object arg)    

 

Line: 54

Char: 13

Code: 0

URI: http://www.shelleenvalley.co.uk/spmtestpage/clientbin/testpage.html

 

 

May 28, 2010 at 5:16 PM

I am using Expression Web 3 and able to implement SlideShow 1.2 and 2.0 successfully.  I could maybe help but your test page URI is 404 [http://www.shelleenvalley.co.uk/spmtestpage/clientbin/testpage.html].

May 28, 2010 at 6:43 PM

Hello BradSmithSC.

Thank you for offering to help. I have been trying many versions which has caused the 404 error.  The latest page is located at

URI: http://www.shelleenvalley.co.uk/spmtestpage/spmtestpage.html

Folder spmtestpage contains spmtestpage.html and data.xml, and I have two sub-folders images and silverlight. The vertigo.slideshow.xap is in the silverlight folder.



May 28, 2010 at 7:49 PM

I had a few minor issues setting mine up in EW3 and was thinking maybe you had the same ones.  You are in luck, one of my issues was referencing the provided themes.  Instead of referencing 'Simple Theme' change this line from:
<param name="initParams" value="ConfigurationProvider=SimpleTheme,DataProvider=XmlDataProvider;Path=data.xml"/>
to
<param name="initParams" value="ConfigurationProvider=XmlConfigurationProvider;Path=Configuration.xml,DataProvider=XmlDataProvider;Path=Data.xml" />

Then place Configuration.xml file in the spmtestpage folder along with the Data.xml file.  Use one of the configuration.xml files from the samples and make changes as desired.

After making changes ensure to save-all files and clear the browser cache to preview.

May 28, 2010 at 9:08 PM


Thank you for the suggestions.

I have tried this.  Still no luck though. Do you have any other thoughts?


 

May 28, 2010 at 10:15 PM

I copied your files into into my site that has a working slideshow.  One by one I changed the references from your files to my files.

The gremlin that appears to be causing the problems is the config file.  When I point to my config file your gallery works but not with your config file.

I started with the config settings from the Configuration Guide and then just changed it to fit my needs.

May 28, 2010 at 11:45 PM

I have rebuilt the config file direct from the Configuration guide.  Still no luck.  

I tried renaming the Vertigo.SlideShow.xap to Vertigo.SlideShow.zip and the result was no different.

May 30, 2010 at 7:17 PM
Check if you have the following files in your files in your spmtestpage folder:
  • Silverlight.js
  • SlideShow.js
  • Vertigo.SlideShow.sln
  • Vertigo.SlideShow.snk
You can get these from the downloads section.
 
After making changes ensure to save all files and clear the browser cache before refreshing preview.  This is very important.
Jun 24, 2010 at 7:38 PM

Sorry for the delay in replying - I have been out of the country.

I did not have the snk file in the tree.  I added it but no success.

I have tried putting these files into different places in the tree - again with no success.

Jun 24, 2010 at 9:21 PM

In the thread above you wrote "vertigo.slideshow.xap is in the silverlight folder".  I have all four of these files in the same folder as my config, data and html files.

I see you get the colored square on your page.  Based on my experience with EW3 there is a file reference missing.  At least that was what happened to me.

In the downloads section I grabbed the entire project not just the smaller package.  I moved this and that around and then eventually it worked.  When I first did this I did not know how to correctly reference a file so I just put most everything into the same folder as my html page.

Jun 25, 2010 at 6:58 PM

I tend to agree that I am missing a file reference - but which one :-)

I have copied the entire project to the site and tried many combinations for locating the various files.

I have noticed that if I set the background parameter in the HTML code I can change the colour of the silverlight box.  However  if I set the background colour in the parameters in the configuration.xml file the silverlight box is unchanged. I am currently trying to figure out if this is a clue to my problem.

Jun 26, 2010 at 4:16 AM

I think I recall a similar situation with the background color.  I think you are getting close.  If a file does not affect the gallery then the gallery does not see the reference file.

Here is how I have my files organized in EW3. I am not sure if all of these files are actually needed but my trouble shooting efforts led to this arrangement.  Of course the location could be different based on how you have files referenced.  I stuck pretty close to the setup from the samples.

Various HTML files
Folder "SlideShow" (purpose of folder is to keep these files separate from main site contents)
Configuration.xml
Data.xml
portfolio.html (the page that contains my gallery)
Settings.StyleCop
Silverlight.js
slideshow.html (I was able to view this before being able to view it on the page where this gallery is inserted "portfolio.html". Do you see the gallery when previewing this file?)
SlideShow.js
Vertigo.SlideShow.sln
Vertigo.SlideShow.snk
Vertigo.SlideShow.xap
Folder "Images" (to house images for gallery)
Folder "SlideShow" (content from SlideShow2 project - listed below)

"SlideShow" folder contents... (first few files of each folder listed for content verification - alphabetically listed)
Folder "Configuration" (Configuration.cs, DarkTheme.cs, LightTheme.cs, ...)
Folder "Controls" (AlbumButton.cs, AlbumPage.cs, AlbumViewer.cs, ...)
Folder "Data" (Data.cs, Data Handler.cs, FlickrDataProvider.cs, ...)
Folder "Navigation" (KeyboardSupport.cs, Navigation.cs)
Folder "Properties" (AppManifest.xml, AssemblyInfo.cs)
Folder "Resources" (Blank.jpg)
Folder "Themes" (Generic.xaml)
Folder "Transitions" (CircleInTransition.cs, CircleOutTransition.cs, CircleTransition, ...)

Be aware I did not list the "_vti_cnf" folders created by EW. Since there is one in every folder and it gets redundant.

Jul 27, 2010 at 5:41 PM
Edited Jul 27, 2010 at 5:42 PM

Something just occurred to me, mere minutes ago, as to why your gallery only shows a blank screen. Your website hosting must support several file types to run this gallery object.

Somewhere deep in the bowels of your hosting options is something likely called MIME file types or similar. Your hosting company likely has hundreds of files already registered. You need to ensure the following are in the list or look for an option to add them.

File Extension and the Content type (MIME):

  • .xaml    application/xaml+xml
  • .xap      application/x-silverlight-app
  • .xbap    application/x-ms-xbap

My hosting provider has this under Configuration and Administration > Webspace > Website Configuration > MIME Types > User Defined > Customer defined MIME types. Your hosting provider likely does not use this structure but hopefully this will help point you in the right direction.

Jul 28, 2010 at 7:10 AM

Many thanks for your continued help.  I must admit I am at a complete loss over what to do.  Following you previous suggestion I believe I have tried every combination of where to locate the files.  I have used developer mode on Chrome - this indicates that the files are being found OK.

I cannot find the setting you have just listed - so I have formally requested confirmation of these from my ISP.  If this works I will post a note and let you know.

Thanks again.